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まずこの本でお勉強まずこの本でお勉強
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加算器のVerilog-HDL
記述を勉強
その後ModelSimでシ

ミュレーション



ＦＰＧＡのデザインフローＦＰＧＡのデザインフロー
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一致検出回路 ｅq.v一致検出回路 ｅq.v
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module eq(s, a, b); /* 一致検出回路 */
input a, b;
output s;
wire na, nb, s1, s2;
assign #5 na = ~a, nb = ~b;
assign #10 s1 = a & b, s2 = na & nb;
assign #10 s  = s1 | s2;

endmodule

module eqSim;    /* 一致検出回路 */
wire s;        /* のシミュレーター */
reg x, y;
eq g1(s, x, y);
initial

begin
$monitor(" %b %b %b", x, y, s, $stime);
$display(" x y s                time");

x=0; y=0;
#50  y=1;
#50  x=1; y=0;
#50  y=1;
#50  $finish;

end
endmodule

⼊⼒宣⾔
出⼒宣⾔

モジュール名

配線宣⾔
接続

遅延

モジュール呼び出し
レジスタ宣⾔

制御記述
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モジュール eqモジュール eq

A B A=B

0 0 １

0 1 ０

1 0 0

1 1 1

module   eq(s, a, b); /* 一致検出回路 */
input  a, b;
output s;
wire   na, nb, s1, s2;
assign #5  na = ~a, nb = ~b;
assign #10 s1 = a & b, s2 = na & nb;
assign #10 s  = s1 | s2;

endmodule

真理値表真理値表 回路図回路図
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シミュレーションモデル eqSimシミュレーションモデル eqSim

module eqSim;    /* 一致検出回路 */
wire   s;        /* のシミュレーター */
reg x, y;
eq g1(s, x, y);
initial

begin
$monitor(" %b %b %b", x, y, s, $stime);
$display(" x y s                time");

x=0; y=0;
#50  y=1;
#50  x=1; y=0;
#50  y=1;
#50  $finish;

end
endmodule
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ModelSimの使い⽅ModelSimの使い⽅
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ModelSimの起動とプロジェクト作成ModelSimの起動とプロジェクト作成
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コンソールで”vsim”と⼊⼒
 File→New→Proeject... で“Create Project”ウィンドウが開く
 Project Name︓ eq
 Project Location︓ C:/J2



Verilog-HDLファイルの追加Verilog-HDLファイルの追加
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 “Add  items to the Project”ウィンドウ︓ Add Existing File
- またはメインウィンドウから Project→Add to Project→Existing File…

 “Add file to Project”ウィンドウ︓ Brows
 “Select files to add to project”ウィンドウ︓

c:/J2/Verilogeq.vを選択して開く．-HDL/
 “Add file to Project”ウィンドウ︓ OK
 “Add  items to the Project”ウィンドウ︓ Close



Verilog-HDLファイルの追加Verilog-HDLファイルの追加
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 C:/J2/Verilog-HDLの下のeq.vを選択して“開く”



コンパイルコンパイル
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メインウィンドウ︓Compile→Compile Selected
 Verilog-HDLファイルのStatusが︖からㇾに変わり、

“Compile of eq.v was successful.”と出る．



コンパイルエラーコンパイルエラー
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1つのコンパイルエラー1つのコンパイルエラー

~aが_aになっている~aが_aになっている

コンパイル失敗コンパイル失敗

エラーがあるとTranscriptウィンドウに⾚く表⽰されるので，
そこをダブルクリックするとエラーの詳細が表⽰される

さらに“** Error: “の⾚い⾏をクリックするとソースコード
ウィンドウが開いてエラーの⾏がオレンジで表⽰される

5⾏⽬のʼ_aʼに⽂法エラー5⾏⽬のʼ_aʼに⽂法エラー



シミュレータ起動シミュレータ起動

Simulate→Start Simulation
Start Simulationウィンドウでwork/eqSimを選択
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シミュレーション設定シミュレーション設定

シミュレーションウィンドウが開く
Add→add to wave→all items in regionで波形ウィンド

ウが開く
“All items in region and below”と”All items in design”

は下位レベルやソースの全ての信号線が表⽰される
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シミュレーション設定シミュレーション設定
ウィンドウが⼩さいので ボタンを押して拡⼤
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シミュレーション実行シミュレーション実行

メインウィンドウで，Simulate→Run→All
Finsh Vsimウィンドウで「いいえ(N)」を選択

- 「はい(Y)」を選択するとModelSimが終了してしまうので注意
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シミュレーション結果表示シミュレーション結果表示
Waveウィンドウに結果が表⽰される
画⾯を⾍眼鏡で拡⼤して表⽰
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ｘ＝ｙ＝０
でｓ＝１

ｘ＝ｙ＝1
でｓ＝１



シミュレーション結果表示シミュレーション結果表示
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シミュレーションモジュールに$monitorコマンドを記述して
いるのでTranscriptウィンドウにテキストでも表⽰される



再シミュレーション再シミュレーション
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メインウィンドウで Simulate→Restart
Restartウィンドウが出るのでOKをクリック
｢シミュレーションの実⾏｣に戻って再シミュレーション
全てのコマンドはTranscriptウィンドウで実⾏されてい

るので，ここに⼿⼊⼒した⽅が早い

←リスタートコマンド←リスタートコマンド
←シミュレーションコマンド←シミュレーションコマンド



内部信号の表示内部信号の表示
Simウィンドウでモジュールを指定し,内部信号を表⽰
$monitor関数では “g1.s1”のようにモジュール内の信号や

さらに”.”でつないでモジュール内のモジュールを指定
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別回路のシミュレーション別回路のシミュレーション
Simulate→End Simulation
Projectウィンドウで右クリックしてポップアップメ

ニューを出し，Add to Project→Existing File...
eq2.vを追加

22
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別回路のシミュレーション別回路のシミュレーション

A B A=B

0 0

0 1

1 0

1 1

module   eq2(s, a, b);
input  a, b;
output s;
wire   s1, s2;
assign s1 = ~(a & b), s2 = a | b;
assign s  = ~(s1 & s2);

endmodule

真理値表真理値表 回路図回路図
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通常回路モジュール内には遅延時間は書かない



別回路のシミュレーション別回路のシミュレーション
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Window内の追加したファイルを選択して，
Compile→Compile Selected(選択したファイルが対象)または
Compile All(すべてのファイルが対象)でコンパイル



別回路のシミュレーション別回路のシミュレーション

25

Libraryタグのworkの下に，eq2とeqSim2ができている
eqSimと同様にeqSim2をシミュレーション

どうなりましたか︖



プロジェクトの変更プロジェクトの変更

File→Close Projectでプロジェクトを閉じる
File→New Projectで新しいプロジェクトを作る

- 前のプロジェクトを閉じていない時は閉じるかどうか聞かれる
Project Name: eq2で新しいプロジェクトを開く

- 他のプロジェクトとモジュールを共有するときや，名前が同じ異な
るモジュールがなければDefault Library Name: workでよい
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プロジェクトの変更プロジェクトの変更
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プロジェクトeqに戻るときはFile→Resent Projectから選ぶ
か，File→Openでファイル選択のポップアップウィンドウの
右下を“Project Files”に切り替えてmpf (Modelsim Project 
File)ファイルを表⽰して選択



問題１問題１

モジュールeqのゲートの遅延時間を0 にしてシミュ
レーションを⾏い、遅延ありのシミュレーションと⽐
較せよ。
それぞれのシミュレーション結果について、各変数の

時間に対する変化を図(または波形)に表し、違いを明
確にせよ。
また、eqの内部端⼦の変化状況が分かるように表⽰し

てみよ。(シミュレーション波形では、”All items in 
region and below”か”All items in design”を設定)
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問題２問題２

変数a, b, c, d を受け取り、a = b とc = d がともに成り
⽴つとき出⼒s を1 に、それ以外のときs を0 にする回路
のモジュールを、モジュールeq を2 個使って作れ。
このとき、シミュレーション⼿続きからeq の内部端⼦は

どのように参照すればよいか。適当なシミュレーション
を⾏い、実⾏例とともに⽰せ。
- “Verilog-HDL 階層参照”でネット検索

29

問題３問題３

設計した組み合わせ回路が正しく動作することを検証す
るためには、シミュレーターをどのように作ったらよい
かを考えよ。そして、レポートにて説明せよ。



順序回路順序回路

実験第⼀ J2課題
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順序回路順序回路

D-FF(Delay:遅延)はクロックckの⽴下り(negedge)に同
期してデータDを取り込み(遅延#10で)Qに出⼒する
cｋは#50ごとに反転する(1周期#100)

31

module clk( ck );
output   ck;
reg ck;
initial     ck = 1;
always  #50 ck = ~ck;

endmodule

module dffn( Q, D, ck );
input    D, ck;
output  Q;
reg Q1;
initial    Q1 = 0;
assign  #10 Q = Q1;
always @( negedge ck ) Q1 = D;

endmodule イベント制御⽂



1ビットの記憶回路1ビットの記憶回路

32

module r1( q, l, d, ck );
input    l, d, ck;
output  q;
wire     nl, s1, s2, d1;
dffn f( q, d1, ck );
assign  #5 nl = ~l;
assign  #10 s1 = nl & q, s2 = l & d;
assign  #10 d1 = s1 | s2;

endmodule

QD q

ck
d

d1

ck

s1

s2

nl
l

QD q

ck
d

q

ck

q

0

1
0

QD q

ck
d

d

ck

0

d

0
1

 制御信号ｌでD-FFへの書き込みを制御
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逐次制御回路逐次制御回路
 現在の状態s1s0，⼊⼒a，出⼒b，次の状態s1ʼs0ʼから状態遷移

図と真理値表を作る

現在の状態s
0 1 2 3

入力
a

0 0/0 2/1 3/1 0/1
1 1/0 2/1 3/1 0/1

s’/ b次状態 現在の出⼒

0/0

0/1, 1/1

0/1,1/10/1, 1/1

1/0

a/b⼊⼒ 現在の出⼒

a s1 s0 b s1’ s0’
0 0 0 0 0 0
1 0 0 0 0 1
x 0 1 1 1 0
x 1 0 1 1 1
x 1 1 1 0 0

33

s1’ = s1･s0 + s1･s0
s0’ = a･s1 + s1･s0
b = s1 + s0
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逐次制御回路逐次制御回路

s1’ = s1･s0 + s1･s0
s0’ = a･s1 + s1･s0
b = s1 + s0

module m1( b, a, ck );
input    a, ck;
output  b;
wire     ns1, ns0, s1, s0, d1, d0, c1, c2, c3;
dffn f1( s1, d1, ck ), f2( s0, d0, ck );
assign  #5    ns1 = ~s1, ns0 = ~s0;
assign  #10 c1   =  s1 & ns0, c2 = ns1 & s0,

c3   = a & ns0;
assign  #10 d1   =  c1 | c2, d0 = c1 | c3,

b   =  s1 | s0;
endmodule

34



状態遷移図状態遷移図
 順序回路を状態遷移図で表記して動作を解析，あるいは状態遷移図か

ら順序回路を設計するときにはFFの値が「状態」を表す
 ⼊⼒と出⼒によってその状態間がどう遷移するかを調べる

 CS実験第⼀J1課題の回路の動作を調べる
- ⼊⼒はE，出⼒はQ1Q0
- 状態はQ1Q0（D-FFから直接なので出⼒と⼀致）
- 2bitなので最⼤で4状態だが，全ての組合せを取らない場合もある

35



状態遷移図状態遷移図
 組み合わせ回路の部分をE=0とE=1の場合に分けて簡単にする。

Q0

D1

D0

Q1

36
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状態遷移図状態遷移図
 真理値表からE,Q1Q0とD1D0の関係を求める

E Q1 Q0 D1 D0

0 Q1 Q0 Q1 Q0

1 0 0 0 1
1 0 1 1 0
1 1 0 1 1
1 1 1 0 0

0

1

0

1

前の状態を保持

(D1D0)2=(Q1Q0)2+1 mod 4

1

0

0

0
1

1 0

0

10

0

1

01

1
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状態遷移図状態遷移図
 現在の状態Q1Q0と次の状態D1D0から状態遷移図を作る

E Q1 Q0 D1 D0

0 Q1 Q0 Q1 Q0

1 0 0 0 1
1 0 1 1 0
1 1 0 1 1
1 1 1 0 0

0/010/00

0/100/11
1/10

1/011/11

1/00

E/Q1Q0

⼊⼒ 現在の出⼒

 クロックTが⼊る毎に状態が変化する
 状態はQ1Q0={00,01,10,11}の4つ
 ⼊⼒はE={0,1}
 E=0ならば状態は変わらない
 この回路では状態Q1Q0がそのまま出

⼒になっている。
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問題４問題４

状態遷移表m2に従って動く回路m2の状態遷移図を書
き、回路を設計せよ。
さらに、モジュールを書き、シミュレーションで動作を

確かめよ。ただし、モジュール内ではreg を使わず、
dffn を⽤いて状態を保持せよ。シミュレーションでは、
クロックと⼊⼒とのタイミングについて注意せよ。
そのシミュレーション結果の何をもって動作確認とした

のかも説明せよ。
- 回路m2は、初期状態0 にあるとき⼊⼒a から1 を受けと

り、さらに、3 回1 を受けると出⼒b から1 を出⼒し、初
期状態0 に戻る。

39

現在の状態s
0 1 2 3

入力
a

0 0/0 1/0 2/0 3/0
1 1/0 2/0 3/0 0/1



加減算回路加減算回路

実験第⼀ J2課題
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多ビットデータの表現多ビットデータの表現
多ビットのデータは，x[3:0]のように配列で表す
 Parameter 宣⾔を使うことでビット数を容易に変更できる
ただし，プログラムのように動的に配列を確保するわけではないの

で，配列の⼤きさをmoduleの引数にすることはできない
module eor4( z, x, y );
input   [3: 0]  x, y;
output  [3: 0] z;
wire [3: 0] nx, ny, z1, z2;
assign  #5 nx = ~x, ny = ~y;
assign #10 z1 = x & ny, z2 = nx & y,

z  = z1 | z2;
endmodule

module eorn( z, x, y );
parameter  n = 8;
input   [n-1: 0]  x, y;
output  [n-1: 0]  z;
wire [n-1: 0] nx, ny, z1, z2;
assign  #5   nx = ~x, ny = ~y;
assign #10 z1 = x & ny, z2 = nx & y,

z  = z1 | z2;
endmodule

41

eorn #4 e(g,a,b)
と呼び出すことで
n=4に指定可能



ビットベクトルビットベクトル

42

module notn( y, x );
parameter       n = 4;
input           x;
output          y;
wire    [n-1:0] w;
assign  #5 { y, w[n-1: 0] }

= ~{ w[n-1: 0], x };
endmodule

x w[0]w[0]

w[1]

w[2]

w[n-1]

y

{ }で信号を囲むことで多ビットのデータが表現できる
 x[3:0] {x[3:2], x[1:0]}  {x[3], x[2], x[1], x[0]}  等は同じ
左シフト︓{x[2:0], 0}  左巡回シフト︓{x[2:0], x[3}
右シフト︓{0, x[3:1]}  右算術シフト︓{x[3], x[3:1]}

下のコードはwを⾃⼰参照しているように⾒えるが，実
際の回路は1ビットずつずらしながらNOTしている．



問題５ (加算回路の設計)問題５ (加算回路の設計)

全加算器(Full Adder)
は下からの桁上げを考
慮した3⼊⼒の加算器

cu=a･b＋a･c＋b･c
s = a･b･c＋a･b･c

+a･b･c＋a･b･c

a b c cu s
0 0 0 0 0
0 0 1 0 1
0 1 0 0 1
0 1 1 1 0
1 0 0 0 1
1 0 1 1 0
1 1 0 1 0
1 1 1 1 1

43

桁上げ cu = a & b | b & c | c & a
和 s = a & ~b & ~c | ~a & b & ~c | ~a & ~b & c | a & b & c

s = a ^ b ^ c
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問題５ (加算回路の設計)問題５ (加算回路の設計)

module add4( cu, s, x, y, ci );
input  [3: 0] x, y;
input         ci;
output        cu;
output [3: 0] s;
wire   [3: 0] c;
fa a3( cu, s[3], x[3], y[3], c[3]),

a2(c[3], s[2], x[2], y[2], c[2]),
a1(c[2], s[1], x[1], y[1], c[1]),
a0(c[1], s[0], x[0], y[0], ci);

endmodule

 全加算器をサブモジュールとして使うと、ビットの⻑さn をパラ
メーターにした記述はできない。ビットのベクトルを使って、n 桁
の加算器をひとつのモジュールで実現せよ。

 このモジュールはadd4 のように、最上位の桁上げcu と、最下位
に加えるci を持つこと。

 さらに、シミュレーションにより評価せよ。

c
fa

a b

scu

c
fa

a b

scu
0

c
fa

a b

scu
1

x0y1

s1

x1y2

s2

x2x3 y3 y0

s0s3

1 0 0 0 1 1 1 1

1

10 011

c
fa

a b

scu

c3 c2 c1 ci

cu
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条件付きassign文条件付きassign文

条件はC⾔語と同じ >,<, >=,<=, ==, != , <=などが，
またその論理積(&&)や論理和(||)などが利⽤できる

45

assign 変数= 条件? 条件が1(真) のときの値:
条件が0(偽) のときの値;

assign z = c? x: 0; assign z = c? x: y; assign z = c? x:
d? y: w;



問題６ ( n ビットレジスター) 問題６ ( n ビットレジスター) 

以下に⽰す仕様のクロックに同期して動作するn ビット
レジスターのモジュール r を設計し、シミュレーショ
ンにより評価せよ。
- データ⼊⼒︓ d,
- 制御信号⼊⼒︓ load,
- データ出⼒︓ q.
- 動作︓ load = 0 のときq = q ,

load = 1 のときq = d.

46
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繰り返し動作の記述繰り返し動作の記述

module sel( z, x, c );
parameter n = 8;
input [n-1: 0] x;
input c;
output [n-1: 0] z;
assign #10 z = c? x: 0;

endmodule

module selSim;
wire [1:0] p;
reg [2:0] v;
sel #2 g(p, v[1: 0], v[2]);
initial
begin
$monitor("%b %b", v, p, $stime);
for ( v=0; v<7; v=v+1 ) #100;
#200 $finish;

end
endmodule

module sel2( z, x, c );
input  [1: 0] x;
input         c;
output [1: 0] z;
assign #10 z[1] = x[1] & c,

z[0] = x[0] & c;
endmodule

for (制御変数の初期設定; 継続条件;
制御変数の変更) 文;

n=2に指定



問題７ (加減算回路の設計) 問題７ (加減算回路の設計) 

以下に⽰す仕様のn 桁の加減算回路のモジュールを設計
し、シミュレーションにより評価せよ。ただし、負の数
は2の補数表現で表されているものとせよ。
- 数の⼊⼒︓ n 桁の整数x, y︔
- 制御信号⼊⼒︓ k︔
- 出⼒︓ 桁上げcu とn 桁の和s︔
- 動作︓ k = 0 のときs = x + y、

k = 1 のときs = x ­ y。
何れの場合にも、cu はaddn からの桁上げを与える。
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負数を2 の補数で表したとき、x − y = x + y + 1 である。した
がって、k の値によってy とy の何れかを選ぶ選択回路の出
力とx を加算すればよく、1 の加算には、桁上げ入力を使う。



問題８ (オプション課題)問題８ (オプション課題)

Xilinx PlanAheadとNEXSYS 3を⽤いて、実際に加算器
を動作させよ．
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FPGAボード NEXSYS 3FPGAボード NEXSYS 3

実験第⼀ J2課題
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佐藤証 ⻄9-613
akashi.satoh@uec.ac.jp



NEXSYS 3の構成NEXSYS 3の構成
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8Mx16bit SRAM

8Mx16bit BPI Flash

128Mbit SPI Flash

SPI: Serial Peripheral Interface   BPI: Byte Peripheral Interface 
VHDC: Very High Density Cable    Pmod: Peripheral Modules

100MHz
Spaltan-6



NEXYS 3のブロック図NEXYS 3のブロック図
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Xilinx開発ツールXilinx開発ツール
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フリー版のISE Design Suite WebPACKを使⽤
- ７シリーズから新しいツールVIVADOが登場
統合環境はVIVADOとユーザインタフェースが共通化され

たPlanAheadを使⽤
- 従来はProject Navigator



UCF(User Constraints File)UCF(User Constraints File)
FPGA実装の制約を与えるファイル
実験ではIOピンの接続を設定
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# 4-bit adder

#LED
NET "cu"   LOC =  M11 | IOSTANDARD = LVCMOS33;
NET "s<3>" LOC =  V15 | IOSTANDARD = LVCMOS33;
NET "s<2>" LOC =  U15 | IOSTANDARD = LVCMOS33;
NET "s<1>" LOC =  V16 | IOSTANDARD = LVCMOS33;
NET "s<0>" LOC =  U16 | IOSTANDARD = LVCMOS33;

#SWITCH
NET "x<3>" LOC =  T5 | IOSTANDARD = LVCMOS33;
NET "x<2>" LOC =  V8 | IOSTANDARD = LVCMOS33;
NET "x<1>" LOC =  U8 | IOSTANDARD = LVCMOS33;
NET "x<0>" LOC =  N8 | IOSTANDARD = LVCMOS33;
NET "y<3>" LOC =  M8 | IOSTANDARD = LVCMOS33;
NET "y<2>" LOC =  V9 | IOSTANDARD = LVCMOS33;
NET "y<1>" LOC =  T9 | IOSTANDARD = LVCMOS33;
NET "y<0>" LOC = V10 | IOSTANDARD = LVCMOS33;

#PUSH BUTTON
NET "c"    LOC = B8  | IOSTANDARD = LVCMOS33;



ピンアサインピンアサイン

Nexsys3の回路図
J2/NEXYS3_sch.pdf
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入出力電圧規格入出力電圧規格
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デフォルトはLVCMOS33
LVCMOS33とLVTTLは同じ0~3.3V動作だが，LVTTL

の⼊⼒は0.8-2.0V間が不安定なため普通は使わない．



PlanAheadを起動PlanAheadを起動
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コンソールで“Planahead”と⼊⼒
Create New Projectをクリック



プロジェクトフォルダを指定プロジェクトフォルダを指定

Project name: add4
Project location: J2/work
Create project Subdirectoryにチェック
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プロジェクトタイプの指定プロジェクトタイプの指定

RTLプロジェクトにチェック
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ソースファイルの指定ソースファイルの指定
Add filesで次のファイルを追加

- J2/Verilog-HDL/add4.v (fa.vなどを適宜作成、追加）
Copy sources into project
Target language: Verilog
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その他のIPを追加その他のIPを追加
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何も指定しない



制約ファイルを追加制約ファイルを追加
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Add filesで次のファイルを追加
- J2/add4.ucf
Copy constraints file into project



デバイスの指定デバイスの指定

Family: Spartan-6
Sub-Family: Spaltan-6 LX
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Package: csg324
Speed grade: -3
Temp grade: C



設定内容を確認設定内容を確認

内容を確認してFinish
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プロジェクトに
含まれるソース

選択したソース
の属性

操作コマンド
のリスト

サマリーやファイルの内容

各処理のログや進⾏状況



コンパイルの実行コンパイルの実行
Sourcesウィンドウでadd4を選んでGenerate Bitstream

を実⾏しYesをクリック
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実⾏中
完了



ビットファイルのFPGAへの書き込みビットファイルのFPGAへの書き込み
Program and DebugのLaunch iMPACTをクリック
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ビットファイルのFPGAへの書き込みビットファイルのFPGAへの書き込み
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書き込みツールが起動．プロジェクトファイルは作成不要．



ビットファイルのFPGAへの書き込みビットファイルのFPGAへの書き込み
Operations→Program
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ビットファイルのFPGAへの書き込みビットファイルのFPGAへの書き込み
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add4の実行add4の実行

SW7-0の切り替えに応じてLEDが点灯する

72

SW7-0

SPI 
ROM

LED


